A sample thesis

by

Adriana Tiamae Dawes

A THESIS SUBMITTED IN PARTIAL FULFILMENT OF
THE REQUIREMENTS FOR THE DEGREE OF
Doctor of Philosophy
in
The Faculty of Graduate Studies
(Mathematics)

The University Of British Columbia
August 14, 2006
© Adriana Tiamae Dawes 2006
Abstract

This is a sample thesis that (for now) satisfies the formatting requirements of UBC grad studies.
# Contents

Abstract .............................................................. ii

Contents .............................................................. iii

List of Tables ........................................................ iv

List of Figures ........................................................ v

1 Formatting .......................................................... 1
   1.1 Getting started ................................................. 1
   1.2 Typesetting equations ....................................... 2
   1.3 Including figures ............................................. 3
      1.3.1 Grace ...................................................... 3
      1.3.2 Plot size ................................................ 3
      1.3.3 Too many unprocessed floats ......................... 3
      1.3.4 Plot arrays ............................................. 3
      1.3.5 Tables .................................................. 3

2 Resources .......................................................... 5
   2.1 Style guides .................................................. 5
   2.2 Peer reviewing ............................................... 5
   2.3 UBC resources ............................................... 5
      2.3.1 The Writing Centre ................................... 5
      2.3.2 Grad studies ........................................... 5
      2.3.3 Counselling services ................................. 6
      2.3.4 TAG ...................................................... 6
   2.4 Good luck ..................................................... 6

Bibliography .......................................................... 7

A Appendix ............................................................ 8

B Getting started with Grace ....................................... 9
   B.1 Generate your data ........................................... 9
   B.2 Start Grace .................................................... 9
   B.3 Modify your plot ............................................. 9
      B.3.1 Importing new data .................................... 9
      B.3.2 Set appearance ....................................... 10
      B.3.3 Axis properties ....................................... 10
   B.4 Save and print your plot .................................. 10
   B.5 Just a start .................................................. 10

---

1You need a footnote if you have published the material in this chapter
List of Tables

1.1 A table ......................................................... 3
List of Figures

1.1 This figure is generated using the simplest possible code. These plots were generated using Grace .............................................. 4
1.2 This figure is generated using an array ............................................ 4
Chapter 1

A really long title that would not make a good running header at the top of the page. Oh, this chapter is about formatting

1.1 Getting started

I used the \LaTeX templates and class files provided by Michael McNeil Forbes and available for download at http://www.phys.washington.edu/users/mforbes/projects/ubcthesis/. Download the file ubcthesis.tar.gz to a new directory and (if you’re on a Linux or Unix machine), type the following commands to unpack the file:

\texttt{tar -zxvf ubcthesis.tar.gz}

If you use Windows, you’re on your own.

You will now have a bunch of files in your directory (you can delete the tar file if you want). Use a text editor to view ubcthesis.dtx and follow the instructions there to generate the class files you need. That file will also tell you how to generate a document that contains information on the various options for these class files.

The sample file you’re looking at now has only two main modifications from the sample thesis provided by Michael Forbes. The additions are:

- Setting the margins: I found the default margins to be way too big (too much white space around the edges). I corrected this by including the package \texttt{geometry} which allows you to specify the margins inside your document (see the file sample.tex).

- Double spacing: Using the committeespacing option causes the figure and table captions to be double spaced as well. To keep the captions on one page, I used the package \texttt{setspace} then the command \texttt{\mbox{\textbackslash doublespacing}} to double space the text while keeping the captions single spaced.

Before compiling this sample thesis, make sure you have all the files you need:

- \texttt{sample.tex} - the main tex file
- \texttt{abstract.tex}
- \texttt{formatting.tex}
- \texttt{fig1a.ps, fig1b.ps, fig1c.ps}
- \texttt{resources.tex}
- \texttt{biblio.bib} - a bibtext file
- \texttt{appendix.tex}
Chapter 1. Formatting

- grace.tex

along with the class files you created above. This sample thesis uses bibtex to create a bibliography. This is more complicated than using the bibliography environment, but makes it much easier to change the style of your bibliography and citations. Once you have a sample file (like the one here!) you can just cut and paste to create your own entries. Then experiment with different bibtex options to find the style you like best.

To compile this file, type the following commands.

latex sample.tex
bibtex sample
latex sample.tex
latex sample.tex

Then to view the file, type

dxvi sample.dvi

To convert the file to postscript for printing, type
dvips -osample.ps sample.dvi
(if you don’t put the -o, the output file would be automatically printed out instead of just creating a .ps file).

To convert the file to pdf, type
dvipdf sample.dvi
This command does not require the -o argument.

Please use a text editor to look at the different files to see how various things are typeset.

1.2 Typesetting equations

There are lots of good guides for typesetting math, including the Not So Short Guide to \LaTeX2e, available for download at:

One package that I am very fond of is the subequations package which numbers equations as follows:

\begin{equation}
\frac{dP}{dz} = -S \tag{1.1a}
\end{equation}

\begin{equation}
\frac{dS}{dz} = \frac{\alpha}{D} P(1 - P) - \frac{v}{D} S \tag{1.1b}
\end{equation}

which is Fisher’s equation and has a nice travelling wave solution.

Notice I haven’t turned off the subequation environment off so I can write another equation, say boundary conditions, and the numbering is continued even though there is text between the equations. Here are the nullclines.

\begin{equation}
S = 0 \tag{1.1c}
\end{equation}

\begin{equation}
S = \frac{\alpha}{v} P(1 - P) \tag{1.1d}
\end{equation}

Without subequation, the equations would look like:

\begin{equation}
\frac{dP}{dz} = -S \tag{1.2}
\end{equation}

\begin{equation}
\frac{dS}{dz} = \frac{\alpha}{D} P(1 - P) - \frac{v}{D} S \tag{1.3}
\end{equation}

followed by:

\begin{equation}
S = 0 \tag{1.4}
\end{equation}

\begin{equation}
S = \frac{\alpha}{v} P(1 - P) \tag{1.5}
\end{equation}
Note the change in numbering style. Choose whichever you like best.

1.3 Including figures

You can look in many different places for information on how to include figures in your \LaTeX document but here are a few tips I figured out the hard way.

1.3.1 Grace

The software Grace (available at http://plasma-gate.weizmann.ac.il/Grace/) is a very nice program for generating 2D plots. It has a bit of a learning curve but you have a lot of control over the appearance of your plots and it will give the plots in your thesis and publications a nice uniform look.

1.3.2 Plot size

Sometimes \LaTeX stuffs all your figures at the end of the file. Often this is caused by the figures being too big for the page and instead of trying to squeeze the figures into the text somewhere, \LaTeX shuffles all of them to the end of the document. If this happens to you, try reducing the size of your plots to something really small (like 1 cm - you will change it back so this is not permanent). If your plots are in the right place with this small size after you compile again, try increasing your plot size gradually until you find the maximum size your plots can be before \LaTeX sticks them at the end.

1.3.3 Too many unprocessed floats

Sometimes \LaTeX will refuse to compile your file and you get the error Too many unprocessed floats. This is due to too many figures (floating objects) that \LaTeX doesn’t know how to handle. This is easily fixed by sticking in the command \clearpage which forces \LaTeX to dump all the figures it’s holding onto and start a new page.

1.3.4 Plot arrays

Here are two ways you can plot multiple figures in one plot. The first example in Figure 1.1 is the easiest. An empty line between \includegraphics commands forces the next plot to be located on the next line (try adding blank lines in different places, recompiling and checking the output). The second example in Figure 1.2 uses the same plots but uses an array to add some text and space the figures. Use whichever you’re comfortable with.

1.3.5 Tables

Here is a sample table.

<table>
<thead>
<tr>
<th>A</th>
<th>Table</th>
</tr>
</thead>
</table>

Table 1.1: A table
Figure 1.1: This figure is generated using the simplest possible code. These plots were generated using Grace.

(a)  
(b)  

Figure 1.2: This figure is generated using an array.
Chapter 2

Resources

Here are some useful resources for writing your thesis (and demonstrate what citations look like). I also list some of the many resources available at UBC that are free for students that have been very useful to me over the years.

It’s free (or close to free)! Your student fees pay for them! Use them!

2.1 Style guides

These references are handy writing style guides.

Strunk Jr. and White (2000) is a classic style guide. The original 1918 version can be viewed for free online at http://www.bartleby.com/141/.

The CBE style guide is also a standard reference for science writing (Committee, 2006) (which was formerly published under the title *CBE Style Manual: A Guide for Authors, Editors, and Publishers in the Biological Sciences*).

2.2 Peer reviewing

The following were helpful resources for me when learning how to peer review a paper: Benos et al. (2003); Kuyper (1991). They also give you tips for what to look for in your own writing.

2.3 UBC resources

There are some great resources at UBC that are free (or cheap) for students.

2.3.1 The Writing Centre

The UBC writing Centre provides one-on-one help with your writing (it’s free for students and they help both English and non-English speakers).

http://www.writingcentre.ubc.ca/

2.3.2 Grad studies

The faculty of grad studies often holds workshops throughout the year on various subjects including grant writing and staying motivated to finish your thesis.

http://grad.ubc.ca/gradpd/

They also offer the services of career counsellors that will give you help with your CV and networking skills. You can also access the resources in the career centre for help with that too.

http://www.careers.ubc.ca/

---

1You need a footnote if you have published the material in this chapter
2.3.3 Counselling services

When you’re really stressed or you feel like your life is getting out of control, go to counselling services. Their services are free for students and they offer workshops on career planning, stress management and many other useful things.
http://students.ubc.ca/counselling/index.cfm

2.3.4 TAG

The Centre for Teaching and Academic Growth offers a number of workshops and has many resources you can access about lots of professional development topics. They have workshops on teaching, giving talks, compiling a CV and teaching dossier and many more.
http://tag.ubc.ca/

2.4 Good luck

Writing a thesis is hard and takes a lot of time and commitment. Good luck and try to have some fun while you’re writing!
Bibliography


Appendix A

Appendix

Here you can put extra stuff like calculations, code, etc.
Appendix B

Getting started with Grace

By popular demand, here is a very quick section on getting started with Grace. This will take you through the process I used to generate Figures 1.1 and 1.2.

B.1 Generate your data

There are a number of ways to do this. The easiest way is to use Matlab or your own C/Java code to produce data. Whatever method you use, make sure your data is formatted so that the x variable is in the first column then your y variables are in the remaining columns. For instance, Figures 1.1 and 1.2 show the functions $y = x$, $y = x^2$, and $y = x^3$. Some lines from the data file look like this (although the plots shown only go from 0 to 1):

0 0 0 0
1 1 1 1
2 2 4 8
3 3 9 27

Note: If you are using Matlab to generate your data, you must use -ascii to save your data, otherwise Grace can’t read it.

B.2 Start Grace

Now that you have your data and it’s properly formatted and readable by Grace, start up Grace. If it is installed on your system, all you need to type is xmgrace on the command line. If it’s not installed, download and install it or ask your sys admin to do it. You can start up Grace with no arguments, which brings up a blank plot. But, you can also start up Grace with your data by using the command:

xmgrace -nxy data.dat

The -nxy argument is essential if you have more than one column of y data (as in the example). Otherwise, Grace thinks you only want to plot the second column versus the first column and ignores everything else.

B.3 Modify your plot

There are countless ways you can edit your plot with Grace. I will list only a basic few. But try pushing buttons at random and see what happens.

B.3.1 Importing new data

Suppose you have more data you want to include on your plot that has different spacing than your original data file, or you started up Grace with no command line arguments. To load up data, use the following commands:
Appendix B. Getting started with Grace

Data → Import → ASCII
It will pop up a box that will let you specify the type of data (remember to choose NXY in “Load as” if your data file has more than one column of y data).

B.3.2 Set appearance
To change the line style in your plot, choose:
Plot → Set appearance
This will allow you to change the line thickness, style, and many other things. To make the changes shown in the plots here, click on the first line in the “Select set:” box (which selects the first y column in the data file). Under “Line properties” change “Style” to a solid line, “Width” to 3 and “Color” to black. Click “Apply” (make sure you do this after every change you want to keep, otherwise Grace will ignore it).

Now click on the second line in the “Select set:” box and do the same thing except for choosing “Style” to be a dotted line. Click “Apply”.

Now click on the third line in the “Select set:” box and do the same again except choose a dashed line for the “Style”. Click “Apply”.

Note: “Accept” is like “Apply” in that it makes Grace recognize the changes you made but “Accept” also makes the dialogue box disappear. If you want to keep making changes, use “Apply”, but when you’re done, use “Accept”. If you don’t want to keep any of your changes and you want to get rid of the dialogue box, click “Close”.

B.3.3 Axis properties
If you want to change the range of the x or y axes, or write some axis labels, click on:
Plot → Axis properties
Use the options on the “Main” tab to change the start and end values of the x or y axes and specify the text for the axis label (make sure the axis you want to modify is the one chosen at the very top). Use the options on the “Axis label & bar” to change the font size of the axis label (very important for posters where you want axis labels to be very big and readable).

B.4 Save and print your plot
Now that you’ve made all the changes you want (and you’ve clicked “Apply” or “Accept”). To save the Grace file, click:
File → Save (or Save as)
Save your file with the extension “.agr”. To export your file as postscript, click:
File → Print setup
and choose “Print to file” and specify a file name (unless you specify a path, the .ps file will end up in the directory where you first opened Grace). Click “Apply” and “Close” or “Accept”.

Now, click: File → Print which will output the .ps file to the specified file name.

B.5 Just a start
There is much, much more you can do with Grace and I think it’s worth taking an hour and going through an online tutorial. Like \LaTeX, Grace has a learning curve but is absolutely worth the effort.